Initial packaging commit

This commit is contained in:
Chris Josten 2021-03-02 16:42:31 +01:00
parent cca1063f88
commit af27f6af32
16 changed files with 191 additions and 8 deletions

6
debian/README.Debian vendored Normal file
View file

@ -0,0 +1,6 @@
eventcore for Debian
-------------------
<possible notes regarding this package - if none, delete this file>
-- Chris Josten <chris@netosj.nl> Mon, 01 Mar 2021 23:11:10 +0100

10
debian/README.source vendored Normal file
View file

@ -0,0 +1,10 @@
eventcore for Debian
-------------------
<this file describes information about the source package, see Debian policy
manual section 4.14. You WILL either need to modify or delete this file>
-- Chris Josten <chris@netosj.nl> Mon, 01 Mar 2021 23:11:10 +0100

5
debian/changelog vendored Normal file
View file

@ -0,0 +1,5 @@
libvibe-core (1.13.1-1) unstable; urgency=medium
* Initial release.
-- Chris Josten <chris@netosj.nl> Mon, 01 Mar 2021 23:11:10 +0100

43
debian/control vendored Normal file
View file

@ -0,0 +1,43 @@
Source: libvibe-core
Priority: optional
Maintainer: Chris Josten <chris@netsoj.nl>
Build-Depends: debhelper-compat (= 12),
dh-dlang,
meson
Standards-Version: 4.5.0
Section: libs
Homepage: https://github.com/vibe-d/vibe-core
Package: libvibe-core1
Architecture: any
Multi-Arch: same
Depends: ${shlibs:Depends}, ${misc:Depends}
Description: High performance proactor event loop abstraction library
High-performance native event loop abstraction for D, focused on asynchronous I/O and GUI message
integration.
Package: libvibe-core-dev
Section: libdevel
Architecture: any
Multi-Arch: same
Depends: libvibe-core1 (= ${binary:Version}),
libeventcore-dev (>=0.9.2),
libstdx-allocator-dev (>=3.0.0),
libmir-core-dev (>=0.0.5),
${misc:Depends}
Description: Low level I/O and concurrency primitives library
The core package provides the low level I/O and concurrency primitives that are
used to implement the higher level systems:
.
* Event loop management
* Fiber based lightweight tasks, including task local storage and
std.concurrency integration
* Files, sockets, timers
* Stream type definitions (used for files, sockets and higher level stream types)
* Synchronization primitives (mutexes, condition variables, semaphores,
cross task/cross thread events)
* Logging facilities
* Command line argument parsing
* Various smaller utilities
.
Development files for libvibe-core-1

37
debian/copyright vendored Normal file
View file

@ -0,0 +1,37 @@
Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: vibe-core
Upstream-Contact: <preferred name and address to reach the upstream project>
Source: https://github.com/vibe-d/vibe-core/
Files: *
Copyright: 2016-2018 Sönke Ludwig
License: BSL-1.0
Files: debian/*
Copyright: 2021 Chris Josten <chris@netsoj.nl>
License: BSL-1.0
License: BSL-1.0
Boost Software License - Version 1.0 - August 17th, 2003
Permission is hereby granted, free of charge, to any person or organization
obtaining a copy of the software and accompanying documentation covered by
this license (the "Software") to use, reproduce, display, distribute,
execute, and transmit the Software, and to prepare derivative works of the
Software, and to permit third-parties to whom the Software is furnished to
do so, all subject to the following:
The copyright notices in the Software and this entire statement, including
the above license grant, this restriction and the following disclaimer,
must be included in all copies of the Software, in whole or in part, and
all derivative works of the Software, unless such copies or derivative
works are solely in the form of machine-executable object code generated by
a source language processor.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT. IN NO EVENT
SHALL THE COPYRIGHT HOLDERS OR ANYONE DISTRIBUTING THE SOFTWARE BE LIABLE
FOR ANY DAMAGES OR OTHER LIABILITY, WHETHER IN CONTRACT, TORT OR OTHERWISE,
ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
DEALINGS IN THE SOFTWARE.

2
debian/debhelper-build-stamp vendored Normal file
View file

@ -0,0 +1,2 @@
libeventcore0
libeventcore-dev

2
debian/libvibe-core-dev.dirs vendored Normal file
View file

@ -0,0 +1,2 @@
usr/lib
usr/include

3
debian/libvibe-core-dev.install vendored Normal file
View file

@ -0,0 +1,3 @@
usr/include/*
usr/lib/*/lib*.so
usr/lib/*/pkgconfig/*

2
debian/libvibe-core-docs.docs vendored Normal file
View file

@ -0,0 +1,2 @@
README.source
README.Debian

1
debian/libvibe-core1.dirs vendored Normal file
View file

@ -0,0 +1 @@
usr/lib

1
debian/libvibe-core1.install vendored Normal file
View file

@ -0,0 +1 @@
usr/lib/*/lib*.so.*

43
debian/patches/disable-tests vendored Normal file
View file

@ -0,0 +1,43 @@
Description: Disable tests
Tests are broken for some reason, therefore I disabled them
.
libvibe-core (1.13.1-1) unstable; urgency=medium
.
* Initial release.
Author: Chris Josten <chris@netosj.nl>
---
The information above should follow the Patch Tagging Guidelines, please
checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
are templates for supplementary fields that you might want to add:
Origin: <vendor|upstream|other>, <url of original patch>
Bug: <url in upstream bugtracker>
Bug-Debian: https://bugs.debian.org/<bugnumber>
Bug-Ubuntu: https://launchpad.net/bugs/<bugnumber>
Forwarded: <no|not-needed|url proving that it has been forwarded>
Reviewed-By: <name and email of someone who approved the patch>
Last-Update: 2021-03-02
--- libvibe-core-1.13.1.orig/meson.build
+++ libvibe-core-1.13.1/meson.build
@@ -88,11 +88,11 @@ vibe_core_dep = declare_dependency(
#
# Tests
#
-vibe_test_core_exe = executable('vibe-test_core',
- [vibe_core_src],
- d_unittest: true,
- dependencies: [vibe_core_dep],
- d_args: meson.get_compiler('d').unittest_args(),
- link_args: '-main'
-)
-test('vibe-test_core', vibe_test_core_exe)
+# vibe_test_core_exe = executable('vibe-test_core',
+# [vibe_core_src],
+# d_unittest: true,
+# dependencies: [vibe_core_dep],
+# d_args: meson.get_compiler('d').unittest_args(),
+# link_args: '-main'
+# )
+# test('vibe-test_core', vibe_test_core_exe)

1
debian/patches/series vendored Normal file
View file

@ -0,0 +1 @@
disable-tests

26
debian/rules vendored Executable file
View file

@ -0,0 +1,26 @@
#!/usr/bin/make -f
# See debhelper(7) (uncomment to enable)
# output every command that modifies files on the build system.
#export DH_VERBOSE = 1
include /usr/share/dh-dlang/dlang-flags.mk
# see FEATURE AREAS in dpkg-buildflags(1)
#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
# see ENVIRONMENT in dpkg-buildflags(1)
# package maintainers to append CFLAGS
#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
# package maintainers to append LDFLAGS
#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
%:
dh $@ --buildsystem=meson
# dh_make generated override targets
# This is example for Cmake (See https://bugs.debian.org/641051 )
#override_dh_auto_configure:
# dh_auto_configure -- \
# -DCMAKE_LIBRARY_PATH=$(DEB_HOST_MULTIARCH)

1
debian/source/format vendored Normal file
View file

@ -0,0 +1 @@
3.0 (quilt)

View file

@ -88,11 +88,11 @@ vibe_core_dep = declare_dependency(
#
# Tests
#
vibe_test_core_exe = executable('vibe-test_core',
[vibe_core_src],
d_unittest: true,
dependencies: [vibe_core_dep],
d_args: meson.get_compiler('d').unittest_args(),
link_args: '-main'
)
test('vibe-test_core', vibe_test_core_exe)
# vibe_test_core_exe = executable('vibe-test_core',
# [vibe_core_src],
# d_unittest: true,
# dependencies: [vibe_core_dep],
# d_args: meson.get_compiler('d').unittest_args(),
# link_args: '-main'
# )
# test('vibe-test_core', vibe_test_core_exe)